Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - sebeta

Páginas: [1] 2 3 4
1
StxLadder - Slicetex Ladder Designer Studio / Reset de contador
« : septiembre 06, 2018, 18:49:44 pm »
Buenas Boris como va? el problema que tengo es que después de terminar el proceso de mi diagrama, debería resetear un contador específico para que no me active una bomba de vacío anclada a un temporizador, pero la primera y segunda vez que realiza el proceso funciona bien, a la tercera vez no me restea el contador, agradecería tu ayuda. Adjunto el programa en donde el contador en cuestión es el C12.

2
SH-300 / Gráfico Temperatura-tiempo
« : julio 19, 2018, 08:26:03 am »
Buen día necesito saber como puedo hacer para que me grafíque correctamente la temperatura en función del tiempo, en la pantalla HMI ya que siempre el gráfico me muestra una línea recta y no puedo ver las variaciones, gracias saludos. Adjunto el programa.

3
SH-300 / Re:SH300 sin respuesta
« : abril 27, 2018, 16:30:08 pm »
boris, logré solucionar el problema del driver, ahora si me conecta el puerto, el tema es que no logra cargar ni compilar el nuevo programa que le quiero cargar, como q intenta pero no lo logra queda en 0%, adjunto imagenes.Espero tu respuesta desde ya muchas gracias.

4
SH-300 / Re:Colocar tiempo en pantalla
« : abril 24, 2018, 17:15:12 pm »
Buenas, tengo otra duda respecto de la pantalla HMI necesito colocar un reloj en la pantalla para que me vaya contabilizando una cierta cantidad de minutos cuando comience un proceso ...

No tengo un ejemplo especifico, pero no es algo complicado de implementar:

En el PLC debes crear una variable entera Int32 llamada por ejemplo ProcesoMin, que tendrá los minutos del proceso.

Luego creas otras dos variables Int32 llamadas ProcesoInicio y ProcesoFin.

Cuando comienza el proceso, llamas al componente "Get Timestamp" en grupo Reloj de Tiempo Real y cargas con un "Timestamp" la variable ProcesoInicio.

Un "timestamp" es un valor entero que representa el numero de segundos transcurridos desde el 01/01/1970 a las 00:00 hs.

Entonces, cuando quieras saber los minutos transcurridos del proceso, cargas el timestamp actual en variable ProcesoFin.

Luego, el calculo de minutos cada vez que lo necesitas, seria:

ProcesoMin = (ProcesoFin - ProcesoInicio) / 60

Finalmente podes utilizar la variable ProcesoMin que tiene  los minutos para cargarlo en un registro ModBus RTU cada X segundos y entonces accederlo desde la pantalla HMI como un registro numérico cualquiera.

...y también necesito que me suene una alarma cuando el mismo culmina, quiero saber si tenés algún ejemplo de como se puede hacer, gracias saludos.

¿Un sonido producido por el HMI te referís?.

Sino, vienen "zumbadores" (buzzer) pequeños que podes colocar a +12V para que suenen cuando una salida rele se activa. Se consiguen en cualquier tienda de electrónica y son económicos.

Saludos
En el el programa de pantalla HMI SH300 existe un ícono que tiene forma de reloj, creí q se podía programar con ese ícono, es por eso que te consulte en esta parte del foro. Adjunto imagen.

5
SH-300 / Re:SH300 sin respuesta
« : abril 24, 2018, 17:08:29 pm »
lo raro es que el win10 si me reconoce que hay un puerto, como se puede ver en la imagen adjunta, pero el programa no me lo reconoce.

6
SH-300 / Re:Colocar tiempo en pantalla
« : abril 24, 2018, 17:05:13 pm »
Me refería a si hay un zumbido que haga la pantalla HMI sin necesidad de nada auxiliar, como cuando enchufas por primera vez la pantalla la misma hace un pitido característico, ese mismo sonido se puede utilizar marcando el fin de un proceso?

7
SH-300 / Re:SH300 sin respuesta
« : abril 23, 2018, 17:36:53 pm »
Puede tener que ver que instalalé en mi computadora el sistema operativo win10?es compatible con  este sistema?

8
SH-300 / Colocar tiempo en pantalla - Sonido
« : abril 23, 2018, 16:30:14 pm »
Buenas, tengo otra duda respecto de la pantalla HMI necesito colocar un reloj en la pantalla para que me vaya contabilizando una cierta cantidad de minutos cuando comience un proceso, y también necesito que me suene una alarma cuando el mismo culmina, quiero saber si tenés algún ejemplo de como se puede hacer, gracias saludos.

9
SH-300 / Re:SH300 sin respuesta
« : abril 23, 2018, 16:26:35 pm »
Buen día boris, te comento que sigo sin poder conectar mi pantalla HMI, reinicie el equipo cambie de puertos, pero nada, te adjunto la imagen de administrador de dispositivos, en donde aparece el puerto conectado, pero el programa no me lo reconoce, tendría que instalar el programa de la pantalla devuelta?

Buenos días.

No aparenta ser un problema del HMI, ya que tenés conexión con el PLC.

Sin embargo, de acuerdo a las capturas de pantallas de PC, tenes algún problema en el cable adaptador USB-SERIE.

No te lo reconoce en la PC y por lo tanto no te figura como puerto COM disponible.

Por lo tanto no es problema del software de la pantalla por lo que veo.

Te recomendaría:

  • Probar programar desde otra PC, por ejemplo una notebook.
  • Cambiar el cable adaptador USB-SERIE-RS232 por otro (si tenés a mano).

El cable adaptador lo podes conseguir en cualquier casa de computación, te recomendaría uno de calidad como los de marca Manhattan que te paso en el siguiente link:

http://www.manhattan-products.com/search?q=205146&As=true&Cid=0&Isc=true&Sid=true

Saludos
Ok voy a tener que comprar uno entonces, vos decís q no es un problema de un controlador?

10
SH-300 / Re:SH300 sin respuesta
« : abril 23, 2018, 08:53:59 am »
Buen día boris, te comento que sigo sin poder conectar mi pantalla HMI, reinicie el equipo cambie de puertos, pero nada, te adjunto la imagen de administrador de dispositivos, en donde aparece el puerto conectado, pero el programa no me lo reconoce, tendría que instalar el programa de la pantalla devuelta?

11
STX8091 / sensor PT100, tensión alimentación
« : abril 11, 2018, 10:30:05 am »
Buenas, según el manual del plc en las entradas analógicas VIN1 utilizada con el jumper 3 se puede utilizar un sensor Pt100 de 4 a 20mA con una tensión de operación de-3 a 3,5 volt, pero esas son tensiones de operación respecto de la corriente que me da el PT100, y la tensión de alimentación de cuanto a cuanto puede ser?puede ser una fuente de 24volt?

12
SH-300 / Re:SH300 sin respuesta
« : abril 09, 2018, 21:43:38 pm »
ha ok te envío el programa como zip, otra cosa que te quería comentar es que la pantalla HMI no me funciona el GCOIL para el inicio del programa, si funciona cuando voy cambiando las pantallas manualmente y se activa la caldera lo puedo ver en la pantalla, pero nada más y la idea es que la con el botón en la pantalla HMI comience el proceso.

Según veo en la pantalla, tenes el botón configurado como "Instant On", ver imagen adjunta:



Esa configuración hace un "1" mientras tenes apretado el botón o por un instante, luego es "0".

En el programa, "Gcoil" será "1" por un instante, fijate que cuando se hace "0" no te pare el programa.

En ese caso, deberias hacer que cuando es "1" active otro flag con "1" (por ejemplo una variable llamada "START") y solo cuando termina el ciclo, se haga "START = 0".

También, en el HMI, podes probar utilizar la opción "Reverse" para que sea "1" si lo apretaste y "0" si lo volvés a apretar.

Saludos


El problema que tengo es que todo esa secuencia de cambios de pantalla e incluso el Gcoil funcionaba antes de conectarlo al autoclave,y ahora que lo conecté no funciona, por eso es que te consulto si puede ser algún error de conexión algo por el estilo, o por algun error de distintas versiones de programas, lo raro es que si me funciona por ejemplo: "bomba de vacío activada" o "bomba de vacío Activada" pero solamente si cambio manualmente las hojas de la pantalla HMI, eso me parece raro.

13
SH-300 / Re:SH300 sin respuesta
« : abril 06, 2018, 18:57:27 pm »
otro problema que se me presento hoy fue que no se si me está leyendo el pt100 los valores de corriente, se puede verificar eso con el virtual HMI?los valores de corriente del pt100 me refiero, interconectando el plc por medio del cable rj45, el problema es que cuando en el proceso inyecto el vapor para la esterilización el pt100 no sensa la presion que tengo programada en el rango de presión, que en el programa es la N017 por ejemplo, me gustaría poder utilizar saber si puedo utilizar el virtual HMI como para ver los valores de corriente(temperatura).

14
SH-300 / Re:SH300 sin respuesta
« : abril 06, 2018, 18:01:05 pm »
ha ok te envío el programa como zip, otra cosa que te quería comentar es que la pantalla HMI no me funciona el GCOIL para el inicio del programa, si funciona cuando voy cambiando las pantallas manualmente y se activa la caldera lo puedo ver en la pantalla, pero nada más y la idea es que la con el botón en la pantalla HMI comience el proceso.

15
SH-300 / Re:SH300 sin respuesta
« : abril 05, 2018, 19:09:50 pm »
ok gracias voy a intentar lo que me decís, te voy a enviar el programa que estoy utilizando para ver si podés encontrar alguna incoherencia en la lógica de conexión entre los dos programas (pantalla HMI y PLC), ya que realicé la programación de tal forma que cuando tenga una entrada de señal (DIN) me cambie automáticamente de screen, eso me funcionó solamente una vez y después no volvió a funcionar. Adjunto programas.
La contraseña del programa de la pantalla Hmi es 0.

Páginas: [1] 2 3 4