Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - MarianoC

Páginas: [1] 2 3 ... 5
1
STX810 / Re:Introduciendo el Módulo STX810
« : febrero 29, 2016, 12:40:50 pm »
Si me arroja el mismo código,  stat = -9 
error.

Enviado desde mi XT1068 mediante Tapatalk


2
STX810 / Re:Introduciendo el Módulo STX810
« : febrero 29, 2016, 12:06:17 pm »
Buenos días, ahora tengo un problema al cargar cualquier programa con StxLadder 1.7.4 me sale un de "timeout", pero le hago "ping" a la placa y se conectan. Ahora cargo cualquier otro programa con StxLadder versión 1.6.9 lo hace sin problema.
A que se puede deber este inconveniente.
Gracias.
Sds.

3
STX810 / Re:Introduciendo el Módulo STX810
« : febrero 26, 2016, 16:44:42 pm »
Buenas tardes, el código que imprime en el LCD es: Stat = -9
                                                                       Error.

4
STX810 / Re:Introduciendo el Módulo STX810
« : febrero 25, 2016, 21:08:55 pm »
Bien, mañana lo pruebo y le comentó los resultados.
Gracias.
Sds.

Enviado desde mi XT1068 mediante Tapatalk


5
STX810 / Re:Introduciendo el Módulo STX810
« : febrero 25, 2016, 16:55:05 pm »
cargo este código y lo mido en el osciloscopio y no mide nada, la señal permanece en 0 mientras que el led sin conmuta de estado. Pero si mido tensión en la salida analógica propia de la placa.

Código: (Pawn) [Seleccionar]
PlcMain()
{
   new Float: Volts
   
   //
   // Inicializar modulo STX810.
   //
   
   Stx810_Init()
   //Stx810_WriteCh(1, 500)
   //Stx810_WriteCh(2, 500)
   //Stx810_WriteCh(3, 500)
   //Stx810_WriteCh(4, 500)
 
   Vout1Write(VOUT1_MID_VALUE)
     
   // 
   // Loop principal.
   //
   
   for(;;)
   {
           //
   // Generar una rampa lineal entre 0 y 10V
   //
   
   if(Volts <= 10)
   {
   Volts += 0.5
   }
   else
   {
   Volts = 0
   }
     
   
        //
// Escribir salidas analogicas con voltaje.
//

Stx810_WriteChVolt(1, Volts)
Stx810_WriteChVolt(2, Volts)
Stx810_WriteChVolt(3, Volts)
Stx810_WriteChVolt(4, Volts)

//
// Pausar 1000 mS.
//

DelayMS(2000)
LedToggle()
      }

   // Retorno.
   return 0
}

6
STX810 / Re:Introduciendo el Módulo STX810
« : febrero 25, 2016, 15:42:45 pm »
Si, lo active antes de cargar el programa.

Enviado desde mi XT1068 mediante Tapatalk


7
STX810 / Re:Introduciendo el Módulo STX810
« : febrero 25, 2016, 15:32:32 pm »
Buenas tardes, he actualizado el firmware y el entorno a 1.7.4 y escribí esta porción de código
     Stx810_Init()
   Stx810_WriteCh(1, 500)
   Stx810_WriteCh(2, 500)
   Stx810_WriteCh(3, 500)
   Stx810_WriteCh(4, 500)
  y no veo esta tensiones a las salidas correspondientes. El led del módulo se encuentra encendido.
Alguna sugerencia para solucionar este inconveniente.
Gracias.
Sds. 

8
STX810 / Re:Introduciendo el Módulo STX810
« : febrero 25, 2016, 12:07:11 pm »
Buenas días, me podrían indicar de donde descargó el firmware para probar el módulo stx810?.
Gracias.
Sds.

Enviado desde mi XT1068 mediante Tapatalk


9
STX810 / Re:Introduciendo el Módulo STX810
« : febrero 12, 2016, 12:45:37 pm »
Bien gracias..
Sds

10
STX810 / Re:Introduciendo el Módulo STX810
« : febrero 12, 2016, 12:22:02 pm »
Buenas, una inquietud que tengo es si el hecho de hacer uso de este módulo de salidas analógicas no me anula el puerto serial de la placa?
Gracias.
Sds.

11
STX8081 / Re: Control del eje de un motor paso a paso
« : diciembre 02, 2014, 18:56:57 pm »
Listo, solucionado intercambie el orden de instrucciones que inicialízan los canales pwm de la siguiente manera:

  //Poner a 0 el duty de ambos canales
   PwmDC(PWM1|PWM2,0)

   //Establezco La fracuencia del PWM
   PwmFreq(2000)
Sds.
Gracias..

12
STX8081 / Re: Control del eje de un motor paso a paso
« : diciembre 02, 2014, 16:47:48 pm »
Disculpas, cuando cargo un programa en blanco no se genera pulsos, pero cuando cargo un programa en el que hago uso de los canales pwm me está generando pulsos o un pulso al resetear la placa con dicho programa cargado.
Sds.

13
STX8081 / Re: Control del eje de un motor paso a paso
« : diciembre 02, 2014, 14:27:49 pm »
Perfecto, ahora no produce ese pequeño pulso al resetear la placa..
Muchas Gracias.. ;D
Sds

14
STX8081 / Re: Control del eje de un motor paso a paso
« : noviembre 28, 2014, 14:58:19 pm »
Si, me hace el mismo efecto aún cuando cargo un programa en blanco..

15
STX8081 / Re: Control del eje de un motor paso a paso
« : noviembre 27, 2014, 14:25:28 pm »
Exacto, así es, al reiniciar la placa, independiente del programa que tengo cargado, me  genera un movimiento del eje del motor...

Páginas: [1] 2 3 ... 5