Comunicación remota STX8091-D1

  • 8 Respuestas
  • 885 Vistas

Mariano

  • Aprendiz
  • **
  • Mensajes: 39
Comunicación remota STX8091-D1
« : febrero 02, 2016, 21:25:21 pm »
Que tal gente,

Tengo instalado el web server en un PLC STX8091-D1 y quiero tener acceso a él desde una
pc remota.

El PLC está conectado a un Router TP-LINK TL-WR740N. Mi pc está conectada al mismo
router.

Una vez cargado el programa al PLC, sucede que tengo acceso a su Servidor desde mi LAN pero no así desde otra pc (o léase: a través de Internet)

El plc tiene cargada la dirección IP 192.168.0.81 ya que la original de fábrica
(192.168.1.81) no me la aceptaba el router por ser una dirección que estaba fuera de su
rango.

Mi IP pública es dinámica... la averigüe en google y supongamos que es 186.XXX.174.YY

Configuré el router para que cualquier requerimiento en el puerto 80 sea derivado a la IP
192.168.0.81 del PLC.

Si hago un ping con el DOS desde la PC remota a la IP 186.XXX.174.YY, la transmisión
se realiza sin problemas aparentes.

Ahora cuando escribo la dirección de mi IP dinámica 186.XXX.174.YY en el chrome no
me accesa al servidor.

Que me puede estar fallando o faltando de configurar o chequear para lograr el acceso remoto?

Saludos

Mariano

Soporte

  • Global Moderator
  • Experto
  • *****
  • Mensajes: 1722
  • Soporte Técnico
Re:Comunicación remota STX8091-D1
« Respuesta #1 : febrero 03, 2016, 07:57:42 am »
Buenos dias,

Es probable que no hayas configurado correctamente la IP del "Router/Gateway IP" en "PLC > Configurar PLC" desde StxLadder.

Alli debes colocar la IP de tu router, en este caso 192.168.0.1, es decir la IP que usas para configurarlo. Te paso una imagen de ejemplo.

Luego resetea al PLC e intenta acceder con la IP dinamica.

Podes averiguar tu IP dinamica con: www.whatismyip.com

Si el router esta bien configurado, deberia acceder. Sino decime  e intentamos ver como configuras el router.

Saludos

Enviado desde un dispositivo móvil usando Taptalk.

SOPORTE TÉCNICO

Slicetex Electronics
www.slicetex.com

Mariano

  • Aprendiz
  • **
  • Mensajes: 39
Re:Comunicación remota STX8091-D1
« Respuesta #2 : febrero 03, 2016, 16:43:51 pm »
Hola Boris,

Estaba configurada esa IP.
Ahora la cambié para dejar la IP de fábrica del PLC.
Quedó el PLC con la IP 192.168.1.81 y l Gateway 192.168.1.1
Aún no puedo lograr la comunicación.
Te adjunto una imagen de la pantalla de forward de mi router.

Saludos


Soporte

  • Global Moderator
  • Experto
  • *****
  • Mensajes: 1722
  • Soporte Técnico
Re:Comunicación remota STX8091-D1
« Respuesta #3 : febrero 03, 2016, 20:40:07 pm »
Buenas tardes Mariano,

Veo que tu router TL-WR740N no tiene interfaz ADSL. ¿ Como te conectas a tu proveedor de internet ?.

¿ Con otro router conectado al TL-WR740N (por ejemplo un modem de Arnet) ?. ¿ Cable modem ?.

Ya que necesitas vincular la IP externa con la IP local, por lo tanto el router debe hacer de "puente" entre ambas interfaces.

Debes configurar el router que se conecta a internet para el "forward".

Aclárame la duda anterior de como te conectas a internet.

Por otro lado, considerando la configuración que me pasas, veo que en la imagen de configuración de tu router el campo "Status" esta Disabled, ponelo en "Enabled". El campo "Protocol" ponelo en "TCP".

¿ Finalmente, no hay algún otro dispositivo que este interfiriendo en el puerto 80 ?

Una prueba facil para esto ultimo, es cambiar el puerto 80 del Web Server del PLC, por el 81 (compilar y transferir el programa nuevamente). Luego en "forward" del router, debes especificar ese puerto en la configuración.

Finalmente, con la IP externa accedes desde el navegador especificando el puerto 81 en la barra de direcciones asi:

http://186.XXX.174.YY:81

Adjunto te paso las imágenes de configuración de nuestro router (si no ves las imágenes en tamaño completo, bajalas con "Guardar enlace como ..."):

  • router_1.png: Esta imagen muestra como se conecta a internet y obtiene la IP externa 181.95.50.130 mediante ADSL, con la interfaz PPPoE.
  • router_2.png: Muestra como esta configurado el forward, puerto 80 a IP 192.168.1.81. Enlaza la interfaz PPPoE (IP externa) con la IP externa en puerto 80.
  • router_3.png: Muestra como agregar el forward.
  • router_4.png: Muestra que el control remoto vía Web del router esta desactivado, ya que por lo general se hace por puerto 80 y por lo tanto podría interferir con la regla anterior.

Aguardo tus comentarios, especialmente de como te conectas a Internet.

Saludos
« Última Modificación: febrero 03, 2016, 20:47:14 pm por Soporte »
SOPORTE TÉCNICO

Slicetex Electronics
www.slicetex.com

Mariano

  • Aprendiz
  • **
  • Mensajes: 39
Re:Comunicación remota STX8091-D1
« Respuesta #4 : febrero 04, 2016, 05:52:01 am »
Hola Boris,

El router recibe un cable ethernet desde un modoem al cual ingresa el par telefónico.
Entiendo que el modem es del tipo ADSL.

Aguardo tus comentarios. Esta tarde verifico todo lo que me dices. En cuanto a la casilla Disabled... lo ví ayer después que te envié el msj, la pasé a Enabled pero tanpoco anduvo.

Saludos

Soporte

  • Global Moderator
  • Experto
  • *****
  • Mensajes: 1722
  • Soporte Técnico
Re:Comunicación remota STX8091-D1
« Respuesta #5 : febrero 04, 2016, 07:49:14 am »
Buenos días Mariano,

Es el módem conectado al par telefonico qué debes configurar el forward, ya que es el router qué hace el enlace entre Internet ADSL y tu red local.

El otro router (WR740N)  debes dejarlo como un simple repetidor, sin forward de puertos, para que no interfiera con el otro. También quizás debas desactivar el DHCP para que no intente asignar IP locales dinámicas en presencia del otro router.

Si es un modem Arnet, entiendo que se pueden configurar el forward de puertos, aunque suelen tener menos opciones.

Saludos

Enviado desde un dispositivo móvil usando Taptalk.
SOPORTE TÉCNICO

Slicetex Electronics
www.slicetex.com

Mariano

  • Aprendiz
  • **
  • Mensajes: 39
Re:Comunicación remota STX8091-D1
« Respuesta #6 : febrero 06, 2016, 20:38:13 pm »
Que tal Boris

Mediante varias pruebas realizadas, no logré ingresar al web server desde una pc remota. Desde mi LAN nunca hubo problema.

En primera medida me gustaría hacer la prueba de ingresar desde mi pc a algún plc que vós conectes en alguna LAN tuya para descartar que no sea problema de la internet local. El servicio que yo tengo lo brinda la cooperativa local. Si puede ser enviame alguna IP pública a la que pueda conectarme para probar.

Te adjunto dos word donde están pegadas las imágenes de configuración de mi router y mi modem para que trates de orientarme para la configuración. Cualquier cosa que esté mal por favor indicámela con el número de figura que le puse a cada imágen para evitar confundir el router y el modem.

Las anotaciones en rojo son los cambios que hice intentando la comunicación. En las otras pantallas no he cambiado nada.

Saludos

Mariano

  • Aprendiz
  • **
  • Mensajes: 39
Re:Comunicación remota STX8091-D1
« Respuesta #7 : febrero 07, 2016, 00:07:22 am »
Ahí funcionó gente!...
Comparto como dí con la solución para cualquiera que este en el tema...
Cambié el puerto en el programa pawn del PLC de 80 a 81 y anduvo el acceso remoto al toque....

Me dí cuenta al ver la pantalla del submenú Remote Management dentro del menú Security del Router TP Link.
o vale decir la figura T11 del word del router que subí en el msj anterior...

Investigando en internet dí con que el puerto 80 es para uso propio del router (en mi caso el TPLINK WR740N); por tanto el router no deja usarlo para el PLC; conclusión: hay que cambiarlo. Como Boris me dijo al 81, le asigné ese y funcionó...

Saludos

Soporte

  • Global Moderator
  • Experto
  • *****
  • Mensajes: 1722
  • Soporte Técnico
Re:Comunicación remota STX8091-D1
« Respuesta #8 : febrero 07, 2016, 13:52:51 pm »
Perfecto Mariano!....

Ya me parecía que podía estar interfiriendo algún otro dispositivo el puerto 80 (ya que es el puerto HTTP por defecto), y por eso entraba en conflicto.

Estamos en contacto. Saludos.
SOPORTE TÉCNICO

Slicetex Electronics
www.slicetex.com