Soluciones al Ruido eléctrico.

  • 2 Respuestas
  • 1477 Vistas

PabloS

  • Novato
  • *
  • Mensajes: 18
Soluciones al Ruido eléctrico.
« : noviembre 06, 2013, 16:20:07 pm »
Bueno, aprovechando que este es un foro, no voy a preguntar nada sino que les voy a comentar cual fue mi problema y espero que puedan aprovecharlo al momento de montar el PLC en el tablero.

Cometí algunos erroes y no fue por no tener el conocimiento, pero desde que me recibí en el secundario, casi que no había hecho nada de electrónica. Y eso que hice la orientación de automatización y control!!!... Pero se me escaparon algunos detalles. Por falta de tiempo yo no monté el PLC sino que lo hizo personal de la fábrica donde trabajo y donde estoy por instalar el PLC, pero no tuvimos en cuenta algunos detalles que luego nos generarian problemas, siendo el mas grave, que el puerto de expnasión dejaba de funcionar.

Primer error
: Al momento de montar el PLC y el puerto de expansión, no tuvimos en cuenta, que quedó mucha distancia entre el PLC y la expansión. Lo cual me obliga a tener un cable de 40cm. Mirando de frente el tablero, creo que lo más óptimo, en el caso del STX8081, es poner la placa del PLC a la izquierda, con los relays hacia la izquierda y el puerto de expansión a la derecha, con los relay hacia abajo. De esta forma, el espacio que queda entre ambas placas va a estar casi libre de cableado (excpeto el cable de red y la fuente del PLC). Con lo cual, el cable plano no cruza sobre cableado que puede inducirle corrientes parásitas.

La etapa de potencia queda a criterio de cada uno. POr mi parte, utilice relay tipo Izumi o Aea, con bobinas de 24 Vac, ya que mucho de los componentes que manejo son electrónicos. Excepto 4 bombas, las cuales conmuto mediante contactores. Es decir que los Relay del PLC manejan una tensión "de control" de 24Vac. No me gusta mucho la idea de manejar directamente 220vac, pero repito, esto va a criterio y experiencia de cada uno.  Pero esto me llevó a cometer el Segundo error: Debido a que el PLC ya estaba mal puesto, y de la manera en que se ordenaron los componentes en el tablero, los cables de 24Vac se me cruzaron con los cables de señal de las entradas discretas. Al desconectar el contactor, y por el fenomeno de autoinducción, mis 24Vac se convertían en picos de 800V. Con lo cual podía ver un leve destello en todos los leds y el puerto serie dejaba de funcionar.

La solución para este problema, sin mover el PLC, fue implementar las sugerencias de Boris las cuales copio:

Citar
- Conectar a tierra la bornera GND del PLC (esto es importante).
- En paralelo a los contactos del relay, podes utilizar algun capacitor de 0.1µF/630V ceramico en serie con un resitor ( de 5 ohms  a 330ohms por ej). Esto disminuye el arco electrico.
- Tambien alejar los cables de potencia del PLC.
- Referir a tierra tambien todos los gabinetes y superficies metalicas cercanas.
 - En lo posible utilizar cables mallados, con la malla conectada a masa.

Desde ya que comencé por lo mas fácil. Verifique las tierras. Noté que la fuente switching para riel DIN de 12Vcc que utilizo para generar los 1 en las entradas discretas, tenía desconectada la masa. También conecté a tierra el borne GND del puerto de expansión.

Por último fui a la casa de electronica y compré los capacitores y una serie de resitencias. Empecé a probar con una resistencia de 220ohms y 100ohms. Pero no había caso. Colocandolo en paralelo al contacto de los relays que manejaban los contactores no funcionaba. En eso se me ocurrió colocar el capacitor de 0,1uF en serie con la resistencia de 220ohms, en parelelo a la bobina del contactor. Y ahí comencé a notar las mejoras. Hice varios test y los leds se dejaron de iluminar. Y además, el puerto funcionó sin caerse en ningun momento.

Después de detectar el problema y lidiar varios días, se puede decir que el problema esta resuelto.


Cualquier cosa que los pueda ayudar, estoy a su disposición.

Pablo.
« Última Modificación: noviembre 06, 2013, 16:23:22 pm por PabloS »

Soporte

  • Global Moderator
  • Experto
  • *****
  • Mensajes: 1642
  • Soporte Técnico
Re: Soluciones al Ruido eléctrico.
« Respuesta #1 : noviembre 06, 2013, 18:36:19 pm »
Perfecto Pablo, muchas gracias por tu aporte!.
SOPORTE TÉCNICO

Slicetex Electronics
www.slicetex.com

PabloS

  • Novato
  • *
  • Mensajes: 18
Re: Soluciones al Ruido eléctrico.
« Respuesta #2 : noviembre 07, 2013, 12:04:56 pm »
Ah y me olvidé de agregar las siguientes recomendaciones, que no tuve que implementar, ya que mi problema venía de otro lado:

Citar
Si es posible, conviene activar las DIN siempre conectando a masa.
Conectar tension a los bornes positivos y luego llevar a masa el borne negativo para producir el UNO.

Filtro de ruido que se le pueden poner a las entradas, serian capacitores de 100 nF o 4.7uF en paralelo al switch que conmuta.

Por otro lado, aprovechando que tengo trifásica, una fase la dejé dedicada a los elementos de control, mientras que las bombas (que no funcionan todas a la vez) las repartí en las otras dos fases.